anything

Author Topic: AutoPolulate keeps kicking in when not supposed to  (Read 8920 times)

Offline caspian

  • Jr. Member
  • **
  • Posts: 64
AutoPolulate keeps kicking in when not supposed to
« on: April 03, 2006, 08:33:50 PM »
I'm using Firefox 1.5.01 on Linux.

I use https://bankname.com for the URL to use. So, whenever I go to https://bankname.com, I'm prompted for my master password, PM fills in my bank's password, and I log in.

But the page I'm taken to is https://bankname.com/accounts.php. PM prompts me for my masterpassword. This happens again and again when I go to various pages on my bank's website.

Could PM be told to autopopulate only if there's a password field on the page?

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
AutoPolulate keeps kicking in when not supposed to
« Reply #1 on: April 03, 2006, 10:22:24 PM »
Hi Caspian,

This isn't really a bug. All you need to do is narrow the "When URL Contains" field to the URL which the bank uses for its login page. Leave "Use This URL" as https://bankname.com (not the specific login page).

-Eric

Offline caspian

  • Jr. Member
  • **
  • Posts: 64
AutoPolulate keeps kicking in when not supposed to
« Reply #2 on: April 03, 2006, 11:54:39 PM »
Hmm... the only problem is that the bank's login page is at https://bankname.com. I guess I could set the "Use this URL" to https://bankname.com/index.php... although I'd rather not have to type "index.php" (Ok, I guess I'm just being picky)

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
AutoPolulate keeps kicking in when not supposed to
« Reply #3 on: April 04, 2006, 01:33:21 AM »
No, "Use This URL" wouldn't help. Only "When URL Contains" controls which URL is used for auto-populate. Are you sure the bank isn't using frames? Can you give me the URL?

Offline caspian

  • Jr. Member
  • **
  • Posts: 64
AutoPolulate keeps kicking in when not supposed to
« Reply #4 on: April 04, 2006, 01:57:42 AM »
Here: https://www.navyfcu.org
And another bank that does something the same way: http://www.virtualbank.com
I've also experienced this with https://www.paypal.com

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
AutoPolulate keeps kicking in when not supposed to
« Reply #5 on: April 11, 2006, 07:19:27 PM »
I can't reproduce this on the site I tried -- paypal.com. Can anyone else?

Offline caspian

  • Jr. Member
  • **
  • Posts: 64
AutoPolulate keeps kicking in when not supposed to
« Reply #6 on: April 12, 2006, 01:55:38 AM »
Here's how to reproduce this problem using Paypal (obviously, you can't log into any of my bank accounts ).

Go to paypal.com and click "Sign Up" (The link on the upper right corner of the page). Then, click "Continue". Now, I have PasswordMaker set to never store my password, so PasswordMaker prompts me for my master password -- I click cancel, but PasswordMaker fills in the name and email address fields with my email address.

I don't know if there's really any workaround to this problem??

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
AutoPolulate keeps kicking in when not supposed to
« Reply #7 on: April 12, 2006, 02:38:59 AM »
OK, a couple questions.

1. Do you have "Auto-populate username & password fields for all sites (can be overridden by individual accounts)" checked for the Default Settings?
2. Do you have an account for paypal.com? If so, please tell me the settings of that account for "When URL Contains", "Automatically populate username and password fields for sites that contain this URL", and any Advanced Auto-Populate options (or none).

Thanks,
Eric

Offline caspian

  • Jr. Member
  • **
  • Posts: 64
AutoPolulate keeps kicking in when not supposed to
« Reply #8 on: April 12, 2006, 03:57:16 PM »
1. No, I don't have "Auto-populate username & password fields for all sites (can be overridden by individual accounts)" checked.
2. Here's my settings for my account with Paypal:
     When URL Contains: https://www.paypal.com
     Use this URL: https://www.paypal.com
     "Automatically populate username and password fields" is checked.

After thinking over this "problem" for a bit, I don't know if it can really be avoided. All the times I'm able to reproduce it is when a password field is present on the page -- and PasswordMaker thinks that it's a login page... so I don't know if there's real workaround, other than to set the "When URL Contains" to https://www.paypal.com/index

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
AutoPolulate keeps kicking in when not supposed to
« Reply #9 on: April 12, 2006, 04:37:18 PM »
I don't understand why this is a bug? This is the way PasswordMaker was designed to behave. In order to specify a specific page or set of pages (instead of all pages) on which to perform auto-populate, the "When URL Contains" field must be refined. How else did you want it to work? I'm confused.

You might consider turning off auto-populate and pressing ALT-` (CoolKey) when you visit PayPal or those other sites. CoolKey will auto-populate the fields but only when you press that key sequence.

Offline caspian

  • Jr. Member
  • **
  • Posts: 64
AutoPolulate keeps kicking in when not supposed to
« Reply #10 on: April 12, 2006, 08:34:55 PM »
Ok... I'm sorry about this. I had thought this was a bug -- but I guess it's not.

Sorry for the inconvenience.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
AutoPolulate keeps kicking in when not supposed to
« Reply #11 on: April 12, 2006, 08:54:44 PM »
No worries. If you have suggestions on an alternative approach, please let me know.

Offline morguns

  • Full Member
  • ***
  • Posts: 145
AutoPolulate keeps kicking in when not supposed to
« Reply #12 on: April 15, 2006, 03:03:54 AM »
this happens to me on some sites also. i just disable auto-populate and use the alt-` coolkey feature; life is good.

PasswordMaker Forums

AutoPolulate keeps kicking in when not supposed to
« Reply #12 on: April 15, 2006, 03:03:54 AM »

 

anything