Author Topic: PasswordMaker Forums Bug  (Read 5218 times)

Offline Tyrantmizar

  • Sr. Member
  • ****
  • Posts: 307
PasswordMaker Forums Bug
« on: July 11, 2005, 08:53:32 PM »
I have only found this to be true on PasswordMaker's forums.  

To reproduce:
1)Go to log in at these very forums.
2)Make sure you have a seperate account for this forum.
3)Alt+`
4)Enter password
5)HERE!!  There are 2 options for your password.  One is the account and one is the default settings.  

I will try to keep this post updated as to the conditions of this bug.
Tyrantmizar
- <a href="http://tyrantmizar.blogsome.com/">Check out my blog</a> (shameless plug :P)
- Lord of the Feature Requests / Enhancements Forum - BWAHAHAHAHA!!!!
- Lord of the other one, the [url=http://forums.passwordmaker.o

Offline Tyrantmizar

  • Sr. Member
  • ****
  • Posts: 307
PasswordMaker Forums Bug
« Reply #1 on: July 11, 2005, 09:01:37 PM »
I think I found out what happens.

For starters:
1)Go to a website that you have an account for (say, www.technorati.com)
2)Open up PM
3)Make sure that the treepicker shows the URL to match (not necessary, makes the bug easier to spot)
4)Open the account settings for the Default Options

5)IMPORTANT! Click on either the URL to match or the URL to use field (should now say, for example, "technorati.com")

NEVERMIND!! Ignore number 5!! Just click 'Okay'

6)Close the account settings dialogue [EDIT]Using Okay[/EDIT] for the Default Options and LOOK AT THE URL TO MATCH.  It should now say technorati.com
7)Sure enough, you will be prompted to choose between the default options and whatever account you're using.

This proves that it actually can be used on any site.
« Last Edit: July 11, 2005, 09:10:49 PM by Tyrantmizar »
Tyrantmizar
- <a href="http://tyrantmizar.blogsome.com/">Check out my blog</a> (shameless plug :P)
- Lord of the Feature Requests / Enhancements Forum - BWAHAHAHAHA!!!!
- Lord of the other one, the [url=http://forums.passwordmaker.o

Offline Tyrantmizar

  • Sr. Member
  • ****
  • Posts: 307
PasswordMaker Forums Bug
« Reply #2 on: July 11, 2005, 09:05:58 PM »
My workaround:

1)Go to about:blank (or any site that you don't use passwords for)
2)Make the URL to match about:blank (using the steps from the previous post)
3)Never tought the default options again!!!!! (unless you need to, of course)

Voila!
« Last Edit: July 11, 2005, 10:09:02 PM by Tyrantmizar »
Tyrantmizar
- <a href="http://tyrantmizar.blogsome.com/">Check out my blog</a> (shameless plug :P)
- Lord of the Feature Requests / Enhancements Forum - BWAHAHAHAHA!!!!
- Lord of the other one, the [url=http://forums.passwordmaker.o

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
PasswordMaker Forums Bug
« Reply #3 on: July 11, 2005, 10:02:26 PM »
Interesting stuff. I'll fix it in a jiffy :)

Thanks,
Eric

PasswordMaker Forums

PasswordMaker Forums Bug
« Reply #3 on: July 11, 2005, 10:02:26 PM »