Author Topic: CoolKey vs. Autopopulate (on specific website)  (Read 6251 times)

Chris

  • Guest
CoolKey vs. Autopopulate (on specific website)
« on: November 10, 2005, 08:30:28 PM »
Just wanted to open with, I love the work you're doing with Passwordmaker.  Here's the problem I'm having, it's actually two fold.

My Bank: http://www.esl.org/

I have an account setup in passwordmaker for this site.  The Coolkey just doesn't work.  This may be due to the login field being named "userNumber", I'm not sure.  Works fine on other sites.

When Auto-populate is on, it does autopopulate my username and password.  But it then proceeds to plop my username into alot of other unrelated fields.  I did a little research and found out the names of the fields it's dropping my username into are:
"amount"
"amount:x" (where x is a number)
"ToAccountNumber"
"ToAccountSuffix"

The ones with "Account" in the name I can understand but why the "amount" fields are being populated I don't get.  The only other thing I've found is that some of the fields are built @ page load by javascript, I don't know if this has any bearing or not tho as others are not.

Honestly, what this all breaks down to is if it's possible to fix things so Coolkey works on this site, I can turn off auto-populate and be happy.

Thanks,
--Chris

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
CoolKey vs. Autopopulate (on specific website)
« Reply #1 on: November 14, 2005, 03:41:36 PM »
Hi Chris,

esl.org has their username/password fields in a frame. I thought I fixed this issue, but apparently not. I'll take a look again and fix it shortly.

Thanks,
Eric

Offline Tyrantmizar

  • Sr. Member
  • ****
  • Posts: 307
CoolKey vs. Autopopulate (on specific website)
« Reply #2 on: November 14, 2005, 08:27:20 PM »
I've been noticing this on some of Google's newer sites, too.  

http://www.google.com/analytics/  and
http://base.google.com

Same problem?
« Last Edit: November 14, 2005, 08:27:30 PM by Tyrantmizar »
Tyrantmizar
- <a href="http://tyrantmizar.blogsome.com/">Check out my blog</a> (shameless plug :P)
- Lord of the Feature Requests / Enhancements Forum - BWAHAHAHAHA!!!!
- Lord of the other one, the [url=http://forums.passwordmaker.o

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
CoolKey vs. Autopopulate (on specific website)
« Reply #3 on: November 15, 2005, 04:31:10 AM »
Just checked those two sites. Yes, same problem: they are in frames. I will fix it shortly.

Marsh

  • Guest
CoolKey vs. Autopopulate (on specific website)
« Reply #4 on: March 14, 2006, 10:30:46 PM »
Quote from: Tyrantmizar
I've been noticing this on some of Google's newer sites, too.  

http://www.google.com/analytics/  and
http://base.google.com

Has this been fixed in the beta builds?  I'm using version 1.4.3 and the autopopulate doesn't work on either of these sites.

(Brilliant extension btw)

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
CoolKey vs. Autopopulate (on specific website)
« Reply #5 on: March 15, 2006, 04:24:06 AM »
Hi Marsh,

Yes, this is fixed in the latest beta (1.5 beta3).

Regards,
Eric

PasswordMaker Forums

CoolKey vs. Autopopulate (on specific website)
« Reply #5 on: March 15, 2006, 04:24:06 AM »