Author Topic: PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock  (Read 7648 times)

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« on: March 22, 2006, 03:43:47 AM »
Hi,

PasswordMaker for Firefox/Mozilla/Netscape/Flock version 1.5 has been released. It will be available here (addons.mozilla.org) shortly. AMO must approve the release before it becomes available.

PasswordMaker for Firefox/Mozilla/Netscape/Flock is no longer available at http://passwordmaker.org as of this release. This is to ensure the download counter at AMO is accurate: AMO issues popularity ratings and extension highlights based on download popularity, which we're missing out on by hosting PasswordMaker on three sites (AMO, passwordmaker.org, and download.com). Moreover, after moving to SourceForge.net hosting, passwordmaker.org no longer has an SSL certificate to secure downloads but AMO does.

Please note: if your current installation of PasswordMaker is from passwordmaker.org and not AMO, you will not be notified about new releases (including 1.5) through Firefox's Extension Manager until you install PasswordMaker from AMO.

Release notes can still be viewed here.

Thanks,
Eric
« Last Edit: March 22, 2006, 04:14:35 AM by Eric H. Jung »

Offline major4579

  • Jr. Member
  • **
  • Posts: 47
PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« Reply #1 on: March 22, 2006, 04:41:51 PM »
Eric,

Looking forward to trying it.. as soon as AMO posts it.
-John

PMW 1.7.1 and FireFox 1.5.0.12 on Windows 2000/SP4

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« Reply #2 on: March 22, 2006, 06:43:22 PM »
And I look forward to your very thorough bug reports, John

Offline Romeo

  • Hero Member
  • *****
  • Posts: 561
PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« Reply #3 on: March 23, 2006, 02:12:23 PM »
How long has it been, now?  Has it been two, or three days, since you submitted 1.5 to AMO ?  I wonder how much longer it'll be before they approve the new version?
It is impossible to create a fool-proof system, because fools are ingenious.

Offline quixin

  • Hero Member
  • *****
  • Posts: 538
PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« Reply #4 on: March 23, 2006, 02:28:29 PM »
Regarding this new feature:
Quote
When creating a new account, "When URL Contains" and "Use This URL" are pre-populated with the current URL.
Would it be possible to have PWM populate the URL using the same URL components set in Default Options?  Right now the two fields in each new account get populated with the entire URL regardless of what is set in Default Options.



Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« Reply #5 on: March 23, 2006, 03:10:52 PM »
Quote
How long has it been, now? Has it been two, or three days, since you submitted 1.5 to AMO ? I wonder how much longer it'll be before they approve the new version?
I submitted it shortly before starting this thread (Mar 21 2006, 10:43 PM EST). Sometimes approval takes a day; other times a week or more. Tyrantmizar is one of the extension reviewers, so maybe he could test it and approve it if he finds the time? Haven't seen him in the forums lately.

Quote
Would it be possible to have PWM populate the URL using the same URL components set in Default Options? Right now the two fields in each new account get populated with the entire URL regardless of what is set in Default Options.
Yes, but can you make this a feature request in the FRL thread so I don't forget about it?

Quote
Please note: if your current installation of PasswordMaker is from passwordmaker.org and not AMO, you will not be notified about new releases (including 1.5) through Firefox's Extension Manager until you install PasswordMaker from AMO.
This is no longer true. I have written a "stub" extension, 1.4.5, which will be posted to passwordmaker.org when AMO approves 1.5. Version 1.4.5 serves only to get you to install PasswordMaker from AMO. Until you install PasswordMaker from AMO, you won't receive automatic update notifications from Firefox's Extension Manager beyond 1.4.5.

BTW, I accidentally hosed 1.4.3 on AMO. Only 1.4.2 is left.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« Reply #6 on: March 23, 2006, 08:16:35 PM »
PasswordMaker 1.5 is now available at AMO.

Offline Romeo

  • Hero Member
  • *****
  • Posts: 561
PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« Reply #7 on: March 23, 2006, 08:39:52 PM »
Eric, I noticed that it is there.  However, when I try to install it, it tells me that it is an invalid package, or some such.
It is impossible to create a fool-proof system, because fools are ingenious.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« Reply #8 on: March 24, 2006, 01:48:46 AM »
It takes a few hours for all the mozilla.org mirrors to get the file. Just hang in there; give it a try tomorrow or later tonight.

PasswordMaker Forums

PasswordMaker 1.5 for Frfx/Moz/Netscp/Flock
« Reply #8 on: March 24, 2006, 01:48:46 AM »