anything

Author Topic: WebDav Backup  (Read 3137 times)

Offline Frosty

  • Normal Members
  • *
  • Posts: 5
WebDav Backup
« on: March 02, 2006, 05:18:18 PM »
Using WebDav backup settings I get corrupt character settings when I download the saved profile.

With both upload and download I get a "Complete" notification indicating all went okay.

The original characters I setup are,
Quote
ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz 0123456789©®¥«»¹²³`~!@#$%^&*()_-+={}|[]\:";'<>?,./

I then upload them via Webdav, close Firefox, wait a couple of seconds, reload Firefox, and then download the settings via Webdav again.

The new characters will then be..

Quote
ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz 0123456789©®¥«»¹²³`~!@#$%^&*()_-+={}|[]\:";'<>?,./

Any ideas?

I am using a local machine with Apache/1.3.34 and libapache-mod-dav on Debian.

Edit: I put a space mid-character list as it was going off-screen.
« Last Edit: March 02, 2006, 05:19:17 PM by Frosty »

Offline Frosty

  • Normal Members
  • *
  • Posts: 5
WebDav Backup
« Reply #1 on: March 02, 2006, 05:24:05 PM »
Looking at the actual file that is saved, it looks like the à symbol is acting like an escape character for non-standard characters.

By avoiding the non-standard characters in my character list, I can use webdav fine. Just means I need to change saved passwods on the web.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
WebDav Backup
« Reply #2 on: March 02, 2006, 05:58:32 PM »
I didn't test upload/download with unicode characters. In fact, testing WebDAV at all was difficult since I couldn't find a WebDAV-enabled server. Would you mind if I had access to your server temporarily so I can fix this problem?

PasswordMaker Forums

WebDav Backup
« Reply #2 on: March 02, 2006, 05:58:32 PM »