Author Topic: Toolbar Icon Bug Still There in 0.8.4  (Read 14394 times)

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Toolbar Icon Bug Still There in 0.8.4
« on: September 20, 2005, 12:41:24 PM »
Hi Eric,

I'm not sure if this is a Windows only problem, and there is another thread here on this, but since there has been no comment from you or anyone else, I thought I'd start a new thread to add a little clarity and hopefully push for a fix. This is a MAJOR cosmetic bug for anyone who is installing the latest version for the first time, and for this reason - and because it should be easy to fix - I think this one should be a TOP priority.

Also, I just confirmed that it still exists in 0.8.4.

The following should help you nail it down... it is easy to reproduce (and workaround)...

It is important to note that this problem ONLY happens if you install >=0.8 in a profile where you never had any other version of PM installed, OR you never placed the icon for any version <=0.7.3 on the toolbar.

To reproduce, start with a clean profile (go to C:\Documents & Settings\username\Application Data\, move the 'Mozilla' folder out to your desktop, start Firefox, let it create a new default profile for you)

Install 0.8.x, then go to View>Toolbars>Customize, you'll see the messed up icons - this is with 0.8-0.8.4.

How to fix:

Uninstall 0.8.x - restart FFox - install 0.7.3 - restart FFox - add the toolbar icon to the toolbar (must do this while 0.7.3 is installed) - restart FFox, uninstall 0.7.3, restart FFox, install 0.8.x - restart FFox - voila, icons are correct.

Tested on XP Pro sp2 and Home, sp2, FFox 1.06

This will fix existing profiles.

Charles

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Toolbar Icon Bug Still There in 0.8.4
« Reply #1 on: September 21, 2005, 05:53:06 AM »
Thanks.... investigating. This may take some time.

Guest

  • Guest
Toolbar Icon Bug Still There in 0.8.4
« Reply #2 on: September 21, 2005, 01:01:24 PM »
No worries - just wanted to make sure you were aware of it - hopefully it will be an easy fix, cause I'm sure this one is biting people using PM for the first time...

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Toolbar Icon Bug Still There in 0.8.4
« Reply #3 on: September 21, 2005, 06:40:08 PM »
dang - did it again...

Offline Miquel 'Fire' Burns

  • Administrator
  • *****
  • Posts: 1157
  • Programmer
Toolbar Icon Bug Still There in 0.8.4
« Reply #4 on: September 22, 2005, 01:50:09 AM »
I just noticed this today myself. Only when it's not on the toolbar does it seem to do that though. (and I don't want to install an older version for now)
"I'm not drunk, just sleep deprived."

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Toolbar Icon Bug Still There in 0.8.4
« Reply #5 on: September 22, 2005, 11:35:20 AM »
I know - it's just a cosmetic bug, but I can see it scaring some people off thinking it is doing something horrible to their nice,. clean FFox install... ;)

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Toolbar Icon Bug Still There in 0.8.4
« Reply #6 on: September 27, 2005, 12:32:06 PM »
Any chance of a fix for this soon? It just bit a friend of mine that I had recommended PM to, and he was a bit put off at first - until he fixed it at my urging and played with it, and is now a convert.

It bit me again yesterday too, when installing a new profile for a new user.

I'd really like to see this fixed - especially since it *should* be easy to do?

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Toolbar Icon Bug Still There in 0.8.4
« Reply #7 on: September 27, 2005, 01:07:00 PM »
Actually, it is already fixed--I just haven't released it yet. I was waiting to put in the new toolbar icon, too (configurable one), but that's going slower than I thought. I can issue a release today :)

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Toolbar Icon Bug Still There in 0.8.4
« Reply #8 on: September 27, 2005, 02:22:50 PM »
Fixed in 0.8.7; available here.

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Toolbar Icon Bug Still There in 0.8.4
« Reply #9 on: September 27, 2005, 03:19:10 PM »
Many thanks!

Ok, now I can get back to bugging you about the feature requests that are near and dear to my heart...

;)

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Toolbar Icon Bug Still There in 0.8.4
« Reply #10 on: October 18, 2005, 02:16:08 AM »
Aaaaargh!!

I just installed 0.9 for my wife, and this bug is back...

It was a fresh/first time install, and the same messed up icons are in the 'Customize Toolbar' window.

Eric? Maybe something with the new icons did it again?

Offline quixin

  • Hero Member
  • *****
  • Posts: 538
Toolbar Icon Bug Still There in 0.8.4
« Reply #11 on: October 18, 2005, 02:33:24 AM »
The bug just hates you tanstaafl! :)

« Last Edit: October 18, 2005, 02:33:49 AM by quixin »



Offline trephin

  • Jr. Member
  • **
  • Posts: 38
Toolbar Icon Bug Still There in 0.8.4
« Reply #12 on: October 18, 2005, 02:35:58 AM »
LOL to the copter

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Toolbar Icon Bug Still There in 0.8.4
« Reply #13 on: October 18, 2005, 06:49:12 AM »
nice one w/ the copter. :)  i haven't reproduced this bug. will try again.
« Last Edit: October 18, 2005, 06:49:21 AM by Eric H. Jung »

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Toolbar Icon Bug Still There in 0.8.4
« Reply #14 on: October 18, 2005, 11:57:10 AM »
Thanks quixin - I haven't laughed that hard this early in the morning in a long time!

heh heh.... :)

In all seriousness - I just confirmed this at the office - moved my working profile, started FFox which created a fresh new one, installed PM 0.9 (the only extension I installed) - bam... both icons producing the dreaded image as shown in this thread.

PasswordMaker Forums

Toolbar Icon Bug Still There in 0.8.4
« Reply #14 on: October 18, 2005, 11:57:10 AM »