Author Topic: HTML not working correctly?  (Read 5914 times)

Offline sasimon

  • Normal Members
  • *
  • Posts: 1
HTML not working correctly?
« on: November 30, 2010, 07:41:05 AM »
Hello.
My name is Stuart Simon. I have been using PasswordMaker because it allows me to log in to websites without having to rely on storing my passwords in the Web and because it allows for the same username/password combination to be used on multiple sites more specific than the second domain.

My problem is that I want to remember the settings I use to generate passwords. I export them to HTML to make them work in browsers and look clean, but that is just a myth. They really come out as something like this:

Account Settings
Defaults
Default settings for URLs not elsewhere in this list

Use l33tnot at all
l33t level1
Hash Algorithmmd5
Password Length8
Protocolunchecked
Subdomain(s)unchecked
Domainchecked
Port, path, anchor, query parametersunchecked
Usernameempty
Modifierempty
CharactersABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789`~!@#$%^&*()_-+={}|[]\:";'<>?,./
Prefixempty
Suffixempty
Automatic Populationunchecked


UWM
empty

NameUWM
Notesempty
Use l33tnot at all
l33t level1
Hash Algorithmmd5
Password Length8
Using Textuwm.edu
Usernamesasimon
Modifierempty
CharactersABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789`~!@#$%^&*()_-+={}|[]\:";'<>?,./
Prefixempty
Suffixempty
Automatic Populationunchecked

Why are there no spaces between the field name and its value? Why does it seem like no stylesheet is being used when the source code refers to "...print.css?" The answer to both of these is that the developer either does not know how to write CSS stylesheets or is confusing them with something else.


You should know that CSS is not HTML. CSS documents have a completely different syntax than HTML documents. They define only the formatting to be applied when a specific HTML or XML tag is activated. If you actually want to link an XML document to an HTML layout, you need to use XSLT. The W3C tutorials will tell you more.  Thanks!!

Stuart

Offline ignatius.reilly

  • Jr. Member
  • **
  • Posts: 28
Re: HTML not working correctly?
« Reply #1 on: November 30, 2010, 11:15:37 AM »
Yeah, the http://passwordmaker.org/Styles/print.css referred to in the generated HTML points by mistake to a wiki page, not a CSS document...

Offline Miquel 'Fire' Burns

  • Administrator
  • *****
  • Posts: 1157
  • Programmer
Re: HTML not working correctly?
« Reply #2 on: November 30, 2010, 09:35:05 PM »
Chances are, that bit was written before the wiki replaced the old page, and no one had used that feature since.
"I'm not drunk, just sleep deprived."

PasswordMaker Forums

Re: HTML not working correctly?
« Reply #2 on: November 30, 2010, 09:35:05 PM »