Author Topic: Firefox 4.0Beta5 Incompatibility  (Read 13259 times)

Offline John Liebson

  • Full Member
  • ***
  • Posts: 123
Firefox 4.0Beta5 Incompatibility
« on: September 08, 2010, 05:30:56 PM »
As the official bearer of bad news, PWM 1.7.8b1 is reported as incompatible, and, although Ctrl+~ did work with Beta4, it does not work with Beta5, nor does PWM appear in the Tools menu.

To add to today's weird confusion with PaperPort, I thought that I had 1.78 installed in Beta4, but I realized that was not so, so I downloaded and installed 1.78, which is indicated as working through Beta6. When that did not work, I tried installing 1.78 in a new Firefox profile with no other extensions; still not Ctrl+~, nor anything in the Tools menu.

(How, after my previous, and incorrect, report about 1.78b1, I managed to get it to work with Beta4, I've quite lost track of. As for PaperPort, which I installed after installing Word Perfect Office X5 yesterday, I have found that one of PaperPort's components, nuanceWPS.exe, takes some 50% of the cpu, and even that, sometimes, when the .exe starts to run, it is impossible to kill the process though the Task Manager. Then there is the oddity that WP Beta4 stopped going to Add-ons a few days ago, and now Beta5 does not go there either--this may be due to a new add-on system being implemented, but I've seen nothing about such.)

Same problem with Beta 6: Ctrl+~  does not work, or Ctrl=`, I just tend to think about tildes, which must be some form of mania.
« Last Edit: September 18, 2010, 05:21:43 PM by John Liebson »

Offline dspectar

  • Normal Members
  • *
  • Posts: 3
Re: Firefox 4.0Beta5 Incompatibility
« Reply #1 on: October 15, 2010, 05:31:28 PM »
Bummer. I've been waiting eagerly for the fix. Is there any post on this forum discussing the latest status? I've seen a few discussing Firefox 4 Beta  but those were all pre-beta 5/6 where we are two.

Offline Miquel 'Fire' Burns

  • Administrator
  • *****
  • Posts: 1157
  • Programmer
Re: Firefox 4.0Beta5 Incompatibility
« Reply #2 on: October 15, 2010, 07:56:00 PM »
Eric usually doesn't focus on beta releases of Firefox. Once the the first RC comes out, then there will soon be a status update.
"I'm not drunk, just sleep deprived."

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: Firefox 4.0Beta5 Incompatibility
« Reply #3 on: October 18, 2010, 03:29:01 AM »
The amount of change between beta releases of Firefox is huge... especially for this 4.x release. So in order to make PasswordMaker compatible with each beta release, it takes a significant effort. Yet few people even use the beta releases. I'd rather spent my time on the Release Candidates, as Miquel points out, than on the betas.

Eric

Offline dspectar

  • Normal Members
  • *
  • Posts: 3
Re: Firefox 4.0Beta5 Incompatibility
« Reply #4 on: October 20, 2010, 05:11:20 PM »
I completely understand. Thanks for all of your effort to make it happen.

According to https://wiki.mozilla.org/Releases, the first RC will be in the second half of October, but they are behind schedule. I imagine it's not too far away.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: Firefox 4.0Beta5 Incompatibility
« Reply #5 on: October 22, 2010, 12:59:58 AM »
Please post here when you are aware of an available RC, and I'll get right on it.

eric

Offline peterstev

  • Normal Members
  • *
  • Posts: 1
Re: Firefox 4.0Beta5 Incompatibility
« Reply #6 on: November 04, 2010, 05:38:34 PM »
This is a chicken or egg problem. I can't really use FF4.0 without PasswordMaker. But if FF4.0 is such a moving target, bummer

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: Firefox 4.0Beta5 Incompatibility
« Reply #7 on: November 05, 2010, 11:19:37 PM »
This is a chicken or egg problem. I can't really use FF4.0 without PasswordMaker. But if FF4.0 is such a moving target, bummer

Indeed. Did you see the recent announcement that Firefox 4 release has been pushed to 2011?
I think the best thing for you is to stick with Firefox 3.x for now until there is a 4.0 Release Candidate. Why the rush to 4.0 beta? I know it's cool, but come on :)

eric

Offline Miquel 'Fire' Burns

  • Administrator
  • *****
  • Posts: 1157
  • Programmer
Re: Firefox 4.0Beta5 Incompatibility
« Reply #8 on: November 06, 2010, 02:53:54 AM »
If you must use Firefox 4 before there's a release candidate, you can always Click!
"I'm not drunk, just sleep deprived."

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: Firefox 4.0Beta5 Incompatibility
« Reply #9 on: November 07, 2010, 01:41:45 AM »
If you must use Firefox 4 before there's a release candidate, you can always Click!

Why does it say "Array ( )" at the bottom of the page?

Offline Miquel 'Fire' Burns

  • Administrator
  • *****
  • Posts: 1157
  • Programmer
Re: Firefox 4.0Beta5 Incompatibility
« Reply #10 on: November 07, 2010, 04:37:05 AM »
Debug thing. Whenever I get the time, I'll fix that. (It's broke in Chrome for some reason)
"I'm not drunk, just sleep deprived."

Offline John Liebson

  • Full Member
  • ***
  • Posts: 123
Re: Firefox 4.0Beta5 Incompatibility
« Reply #11 on: November 10, 2010, 08:55:57 PM »
Please post here when you are aware of an available RC, and I'll get right on it.

eric
http://www.mozilla.com/en-US/firefox/beta/ :Beta 7 for Windows released a short while ago. My understanding is that this beta release is considered to be the first one usable by extension wirters.

Here's the "missing link," which I did not have yesterday, to the document on making extensions work with Firefox 4.x:

http://blog.mozilla.com/addons/2010/11/11/making-add-on-compatible-firefox-4/
« Last Edit: November 11, 2010, 06:41:33 PM by John Liebson »

Offline dspectar

  • Normal Members
  • *
  • Posts: 3
Re: Firefox 4.0Beta5 Incompatibility
« Reply #12 on: November 29, 2010, 07:33:45 PM »
I wish I could use the Click link Miquel points out. But I have my password maker customized considerably. So the defaults just don't work. I wish there was a way to parse the passwordmaker.rdf so Click or equivalent would work.

Oh well. Waiting eagerly for firefox 4 RC.

I use Firefox 4 because it's nice in many ways. But I just use it on my experimental computer. So thankfully when I want to use password maker to login somewhere, I just go to a separate computer.

PasswordMaker Forums

Re: Firefox 4.0Beta5 Incompatibility
« Reply #12 on: November 29, 2010, 07:33:45 PM »