Author Topic: Problem migrating from FFox 3.5.7 to FFox 3.6  (Read 4828 times)

Liam

  • Guest
Problem migrating from FFox 3.5.7 to FFox 3.6
« on: January 25, 2010, 09:17:02 AM »
Hi,

just starting to try passwordmaker: installed it 4 days ago on FFox 3.5.7, all default options as a test, was working fine.

Then upgrated browser to 3.6 and there is a problem.

Passwordmaker no longer correctly identifies the URL for pages (and therefore the generated password is incorrect).

Example: the login page for ebay.co.uk is something like https://signin.ebay.co.uk/ws/eBayISAPI.dll?SignIn&ru=http%3A%2F%2Fwww.ebay.co.uk%2F. In ffox 3.5.7 passwordmaker identifies this as "ebay.co.uk". fine.

In ffox 3.6, it identifies is as "co.uk". Which is not fine.

If I manually change the field to be "ebay.co.uk" in ffox 3.6 then the generated p/w is the same, of course, but this is not a proper solution.

For now have rolled back to 3.5.7 ... is there a known fix for this issue?

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1363
Re: Problem migrating from FFox 3.5.7 to FFox 3.6
« Reply #1 on: January 25, 2010, 12:26:59 PM »
Hi,

just starting to try passwordmaker: installed it 4 days ago on FFox 3.5.7, all default options as a test, was working fine.

Then upgrated browser to 3.6 and there is a problem.

Passwordmaker no longer correctly identifies the URL for pages (and therefore the generated password is incorrect).

That is not entirely correct. I have yet to find a URL that it doesn't work with for any of my accounts. Of course it is possible you have found one before I have, but I just tried 5 random accounts of mine and they all work fine...

Quote
Example: the login page for ebay.co.uk is something like https://signin.ebay.co.uk/ws/eBayISAPI.dll?SignIn&ru=http%3A%2F%2Fwww.ebay.co.uk%2F. In ffox 3.5.7 passwordmaker identifies this as "ebay.co.uk". fine.

In ffox 3.6, it identifies is as "co.uk". Which is not fine.

If I manually change the field to be "ebay.co.uk" in ffox 3.6 then the generated p/w is the same, of course, but this is not a proper solution.

For now have rolled back to 3.5.7 ... is there a known fix for this issue?

Well, I don't think I have any ... hmmm ... I just went and looked, and the 'Special Domains' tab is now blank... I think that is your problem...

Eric? Can you confirm, and if so, any chance this is a quick fix for the old PWM?

I apologize but I've just been too busy to properly test Abine. The last time I looked though I think it will be something I will be able to migrate too, I just need a weekend to give it my full attention... maybe next weekend, since things are starting to slow down a bit...

Offline katala

  • Normal Members
  • *
  • Posts: 9
  • Amateur Cryptographer
Re: Problem migrating from FFox 3.5.7 to FFox 3.6
« Reply #2 on: January 25, 2010, 07:34:57 PM »
I've just upgrade, and use PWM 1.7.2, so far so good, no issues.
Thank you.


Kq

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1363
Re: Problem migrating from FFox 3.5.7 to FFox 3.6
« Reply #3 on: January 25, 2010, 07:45:10 PM »
I've just upgrade, and use PWM 1.7.2, so far so good, no issues.

Interesting - is your 'Special Domains' tab blank?

Liam

  • Guest
Re: Problem migrating from FFox 3.5.7 to FFox 3.6
« Reply #4 on: January 26, 2010, 09:16:33 AM »
Indeed it is (in ffox 3.6): special domains tab is blank.

In 3.5.7 it's full of a raft of stuff.

So I guess that's bad then :-)


Liam

  • Guest
Re: Problem migrating from FFox 3.5.7 to FFox 3.6
« Reply #5 on: January 26, 2010, 11:21:38 AM »
BTW I am using passwordmaker 1.7.3

1.7.2 complained for me that it was not compatible with FFox 3.6 and wouldn't run at all.

I could disable the compatibility checking in Ffox I suppose ... but I haven't tried that yet.

And a minor UI niggle: 1.7.3 identifies itself as 1.7.2 on the about screen and 1.7.3 in the addons menu

Offline katala

  • Normal Members
  • *
  • Posts: 9
  • Amateur Cryptographer
Re: Problem migrating from FFox 3.5.7 to FFox 3.6
« Reply #6 on: January 26, 2010, 03:46:38 PM »
I've just upgrade, and use PWM 1.7.2, so far so good, no issues.

Interesting - is your 'Special Domains' tab blank?


Yes, I see it now.  It doesn't affect my pw as I don't have any sites that use it.

But its content has been wiped clean, its a bug!

Thank you.


Kq

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3348
    • http://passwordmaker.org/
Re: Problem migrating from FFox 3.5.7 to FFox 3.6
« Reply #7 on: January 26, 2010, 07:38:19 PM »
hmmmm... I will look at this shortly. Hopefully, it's a quick fix.

eric

PasswordMaker Forums

Re: Problem migrating from FFox 3.5.7 to FFox 3.6
« Reply #7 on: January 26, 2010, 07:38:19 PM »

 

anything