Author Topic: on-line page not working with Windows Vista + IE 7.0.6001  (Read 9815 times)

Offline cda

  • Normal Members
  • *
  • Posts: 1
on-line page not working with Windows Vista + IE 7.0.6001
« on: September 01, 2009, 06:45:11 AM »
On http://passwordmaker.org/passwordmaker.html

IE displays the page but does not generate a password.

The error reported is

   Line 440 Char 1
   Error: 'AddEventListener' is undefined
   Code: 0

Any clue as how to make it work ?

Thank you in anticipation.

---

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: on-line page not working with Windows Vista + IE 7.0.6001
« Reply #1 on: September 01, 2009, 10:09:12 AM »
Quote
IE displays the page but does not generate a password.

IE hasn't been supported for a long time.

Quote
Any clue as how to make it work ?

Use Firefox.

Offline jarvis

  • Normal Members
  • *
  • Posts: 5
Re: on-line page not working with Windows Vista + IE 7.0.6001
« Reply #2 on: September 01, 2009, 04:16:31 PM »
Sometimes one may be forced to use IE, e.g. at work or more likely at an internet access terminal in a library where you can't even get to a desktop, never mind add a widget / add-on.

I suppose the mobile version still works, but that sends your password across the net.

Also, from the on-line PasswordMaker page:
Quote
Compatibile Browsers
Internet Explorer 5.0, 5.5, 6.0, 7.0
Safari 1.3, 2.0, 3.1
Firefox 1.0.x, 1.5 beta, 2.0, 3.0
Mozilla 1.7.5
Opera 7.54u2
Netscape 7.2, 8.0
Konqueror 3.3 (without cookie support)
Maxthon Browser 1.3.1
Flock 0.5
We haven't found any modern browser with which this page doesn't work. If you've tried this page with another browser or browser version, please let us know!

The words let us know are a hyper-link to this forum!

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: on-line page not working with Windows Vista + IE 7.0.6001
« Reply #3 on: September 01, 2009, 05:01:15 PM »
Ooops... my bad, I though you were talking about the extension/addon...

So this was with IE7? or 8?

Offline Miquel 'Fire' Burns

  • Administrator
  • *****
  • Posts: 1157
  • Programmer
Re: on-line page not working with Windows Vista + IE 7.0.6001
« Reply #4 on: September 01, 2009, 06:38:08 PM »
The line number tells me IE 6 or 7 (I just tried all three, and none works)

I wonder how long that's been broken? VERY simple fix however. I'll update everything shortly.
"I'm not drunk, just sleep deprived."

Offline jarvis

  • Normal Members
  • *
  • Posts: 5
Re: on-line page not working with Windows Vista + IE 7.0.6001
« Reply #5 on: September 01, 2009, 09:09:36 PM »
The line number tells me IE 6 or 7 (I just tried all three, and none works)

I wonder how long that's been broken? VERY simple fix however. I'll update everything shortly.

Great, thanks!  I'm sure the OP will be pleased too.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: on-line page not working with Windows Vista + IE 7.0.6001
« Reply #6 on: September 01, 2009, 09:34:01 PM »
The fix has been committed (thanks, Miquel). Did you have a chance to move it out to the sourceforge site?

Eric

Offline Miquel 'Fire' Burns

  • Administrator
  • *****
  • Posts: 1157
  • Programmer
Re: on-line page not working with Windows Vista + IE 7.0.6001
« Reply #7 on: September 01, 2009, 11:19:40 PM »
It's on the main wiki site now. I think I have the sourceforge site redirecting it to the wiki version as well.

But yea, it's up.
"I'm not drunk, just sleep deprived."

PasswordMaker Forums

Re: on-line page not working with Windows Vista + IE 7.0.6001
« Reply #7 on: September 01, 2009, 11:19:40 PM »