Author Topic: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?  (Read 10754 times)

Chris

  • Guest
PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« on: May 05, 2009, 07:24:04 PM »
Hi there,

My colleague at work is having all kinds of trouble with this particular configuration.  About 50% of the time, PasswordMaker does not function -- the hotkey does not work, and under Tools > Add-Ons > PasswordMaker, it says that the add-on is not compatible with this version of Firefox.

Specific details on his system:
- Vista Business SP1
- Firefox 3.0.10
- PasswordMaker 1.7.2

We use PasswordMaker all the time for our logins at work, and it's never given us a problem before.  What can be done to ensure that my coworker won't continue to experience this issue?  Thanks in advance for any assistance.

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #1 on: May 05, 2009, 07:57:06 PM »
I don't use Vista (<shudder>), and don't have it set up in a VM (no desire, or reason until now), so cannot confirm, sorry...

Is he the only one with this config?

Also, have you tried it with UAC disabled?
« Last Edit: May 05, 2009, 07:58:48 PM by tanstaafl »

Chris

  • Guest
Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #2 on: May 05, 2009, 08:25:38 PM »
Also, have you tried it with UAC disabled?

Forgive the newb question, but what do you mean by UAC?

(Also, I don't blame you for avoiding Vista like the plague. I'm holding onto my XP box at work like a life preserver.)

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #3 on: May 05, 2009, 08:58:43 PM »
UAC = User Access Controls = one of the changes with Vista that gives many people fits... I actually think its a step up as far as security is concerned, but a bad implementation... I understand Windows 7's implementation is much better.

The more I read about Windows 7, the more the whole Vista charade reminds me of the Windows ME debacle. they release something too soon (ME/Vista), then let everyone work out the bugs, then release what should have been the next version (XP/7)...

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #4 on: May 05, 2009, 11:41:59 PM »
I have vista available and will test.

Chris

  • Guest
Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #5 on: May 06, 2009, 02:14:42 PM »
I have vista available and will test.

Great! Would still really like to get this working. Don't want to have to switch to another password manager.

Chris

  • Guest
Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #6 on: May 07, 2009, 10:02:07 PM »
Eric, any word on testing for this issue?

Offline quixin

  • Hero Member
  • *****
  • Posts: 538
Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #7 on: May 10, 2009, 01:07:09 PM »
I'm running Vista and 3.0.10 without problems...

Have you tried a new FF profile with PWM alone installed?



Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #8 on: May 11, 2009, 10:08:10 AM »
Oh... what other extensions does he use? Did you compare with yours to see if it might be one of them interfering?

Also, is Tools > Options > Security > 'Remember passwords for sites' enabled or disabled? Check yours too...

Thats about the only other things I can think of...

Offline jakeaust

  • Normal Members
  • *
  • Posts: 1
PWM + WinXP + Firefox 3.0.10 = incompatiblity issues?
« Reply #9 on: June 03, 2009, 02:38:54 PM »
I am having the same issue as the below described. I am on Windows XP, however. Otherwise the same: PasswordMaker 1.7.2 and Firefox 3.0.10.

Usually the extension doesn't load when I first launch FF. If I go into the "Add-ons" panel, it often tells me that I need to restart FF to "complete my changes" - even though I haven't changed anything. If I see that message, I click the restart button in the panel and when FF relaunches, PasswordMaker is loaded and active.

However, many times I do not get that message. Instead the PasswordMaker 1.7.2 Add-on has a red exclamation mark on it and it says "Not Compatible with Firefox 3.0.10".

I've disabled every other "Extension" Add-on and still no luck. Do I need to start disabling "Plugin" Add-ons?

Below is my list of extensions. You'll see I've disabled almost everything. One thing I noticed is that PasswordMaker is tagged as being compatible up to FF 3.0b3pre. Since 3.0.10 is higher, does the "works with" tag just need to be updated?

Application: Firefox 3.0.10 (2009042316)
Operating System: WINNT (x86-msvc)

- BitDefender Antiphishing Toolbar 2.0
   (Disabled)
   http://www.bitdefender.com
   Firefox 2.0 - 3.0.*
   BitDefender Antiphishing Toolbar
- Drag & Drop.io 2.0.1
   (Disabled)
   http://drop.io
   Firefox 3.0 - 3.1b2
- Extension List Dumper 1.14.1
   http://sogame.awardspace.com/
   Firefox 1.5 - 3.0.*
   Dumps a list of the installed extensions.
- Java Console 6.0.12
   Firefox 1.0 - 5.0+
- Java Console 6.0.13
   Firefox 1.0 - 5.0+
- Java Quick Starter 1.0
   (Disabled)
   Firefox 1.5 - *
- Microsoft .NET Framework Assistant 1.0
   (Disabled)
   http://www.windowsclient.net/
   Firefox 1.5 - 3.0.*
   Adds ClickOnce support and the ability to report installed .NET versions to the web server.
- PasswordMaker 1.7.2
   (Disabled, Incompatible)
   http://passwordmaker.org/
   Firefox 1.0 - 3.0b3pre
   Creates and manages passwords and other account information.
- SearchIMDB 1.0.2
   (Disabled)
   http://sogame.awardspace.com/
   Firefox 2.0 - 3.0.*
   Search the highlighted text at IMDB.
- Who Is This Person? 1.1.1
   (Disabled)
   http://www.spideysenses.com
   Firefox 1.0 - 3.0.*
   Search names in LinkedIn, Wikipedia, Wink, Facebook, Google, Yahoo, ZoomInfo, Technorati, IMDB and many more.
- XUL Cache 1.0
   Firefox 1.5 - 3.*
   XUL cache support for firefox extensions/plugins.




Hi there,

My colleague at work is having all kinds of trouble with this particular configuration.  About 50% of the time, PasswordMaker does not function -- the hotkey does not work, and under Tools > Add-Ons > PasswordMaker, it says that the add-on is not compatible with this version of Firefox.

Specific details on his system:
- Vista Business SP1
- Firefox 3.0.10
- PasswordMaker 1.7.2

We use PasswordMaker all the time for our logins at work, and it's never given us a problem before.  What can be done to ensure that my coworker won't continue to experience this issue?  Thanks in advance for any assistance.

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #10 on: June 03, 2009, 06:13:16 PM »
Sounds like your Profile is seriously messed up...

First thing to do is try with a clean profile...

I use it with dozens of different PCs on XP, with zero problems (much less like what you describe)...
« Last Edit: June 03, 2009, 06:14:47 PM by tanstaafl »

PasswordMaker Forums

Re: PWM + Vista + Firefox 3.0.10 = incompatiblity issues?
« Reply #10 on: June 03, 2009, 06:13:16 PM »