Author Topic: Mask Generated Passwords option not saved  (Read 5795 times)

Offline gforeman99

  • Normal Members
  • *
  • Posts: 1
Mask Generated Passwords option not saved
« on: November 18, 2008, 07:15:54 PM »
After closing and re-opening PasswordMaker, this global settings checkbox becomes unchecked.  This is a bit of a pain, as it basically results in my generated passwords showing up in plain text anytime I'm in a hurry.  I've seen this bug reported a while back, but wanted to re-report it with some more details since I didn't see a resolution.  Here are the detailed steps to reproduce:

Firefox 3.0.1
Windows XP SP2
PasswordMaker 1.7.2

1.  Open a new instance of Firefox
2.  Hit "Ctrl + `" to open PasswordMaker
3.  Go to the "Global Settings" tab
4.  Let's assume that "Mask Generated Password with Asterisks" is unchecked.  Check it.
5.  Type a few characters in the Master Password field, let's say "asdf"
6.  Click the "Close" button in the lower-right
7.  Open PasswordMaker again with "Ctrl + `"
8.  Note that "Mask Generated.." is still checked
9.  Type a few characters in the Master Password field again.  I'll type "asdf" again for my example.
10.  Click "Close"
11.  One more time, open the tool using "Ctrl + `"
12.  Now the "Mask Generated Password with Asterisks" is unchecked.

Sometimes I see the problem happen after step 7, but it always happens after step 11.  Hope this helps.
« Last Edit: November 18, 2008, 07:17:51 PM by gforeman99 »

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: Mask Generated Passwords option not saved
« Reply #1 on: November 22, 2008, 04:48:38 PM »
I guess it is a bug, but there are two simple workarounds...

Simply check the checkbox then click close WITHOUT typing anything in the MW box...

Then re-open PWM - it is still checked.

or

Open, PWM, type something into the MPW box FIRST, THEN check the checkbox, it also stays checked after you close/reopen it...

PasswordMaker Forums

Re: Mask Generated Passwords option not saved
« Reply #1 on: November 22, 2008, 04:48:38 PM »