Author Topic: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken  (Read 11977 times)

Offline TheBashar

  • Normal Members
  • *
  • Posts: 3
PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« on: December 07, 2007, 04:50:05 AM »
Is this a known issue?  Running PasswordMaker 1.7 firefox extension on Firefox 3 beta 1, under Vista I can't edit the default account settings.  The OK / Cancel buttons have no text labels and are inoperative.  I have to use the [X] to close the dialog.


Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #1 on: December 07, 2007, 03:40:51 PM »
PasswordMaker has not been updated to work with Firefox 3. You shouldn't be able to install it with Firefox 3.

Offline TheBashar

  • Normal Members
  • *
  • Posts: 3
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #2 on: December 08, 2007, 01:45:23 AM »
PasswordMaker has not been updated to work with Firefox 3. You shouldn't be able to install it with Firefox 3.

Yes, that's correct.  Just wanted to make sure that it's difficulties under FF3 were known issues.

Cheers,
TB

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #3 on: December 08, 2007, 01:53:04 AM »
Yes, that's correct.  Just wanted to make sure that it's difficulties under FF3 were known issues

I wouldn't really say they're "known issues" since I haven't done any testing of PasswordMaker under FF3 yet. I expect there to be lots of incompatibilities, though.

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #4 on: December 12, 2007, 04:23:13 PM »
Hey Eric,

Any idea when you might get time to look into FF3 compatability? I'm thinking of starting to play with it, and of course, would be lost without PWM... ;)

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #5 on: December 12, 2007, 05:33:00 PM »
I'll take a look this weekend.

Offline John Liebson

  • Full Member
  • ***
  • Posts: 123
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #6 on: December 13, 2007, 02:56:34 PM »
Perhaps this will assist you in updating PWM for FF3: Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007121305 Minefield/3.0b3pre - Build ID: 2007121305 and other recent nightly releases, PWM 1.7 works partially. I installed PWM and copied the passwordmaker.rdf file from my FF profile for FF 2.x into my profile for FF3.

Existing entries in PWM (from FF 2.x) work in the FF nightlies, so that when I go to a site that has a password setup in PWM, PWM properly enters the relevant information and I can log on.

However, if I look at PWM itself, all (yes, all) of the boxes for entering information are empty. So, if I want to see that the password, URL, etc., are for sites where PWM is working with FF3 nightly releases, I see nothing at all.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #7 on: December 13, 2007, 03:47:13 PM »
Perhaps this will assist you in updating PWM for FF3: Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007121305 Minefield/3.0b3pre - Build ID: 2007121305 and other recent nightly releases, PWM 1.7 works partially. I installed PWM and copied the passwordmaker.rdf file from my FF profile for FF 2.x into my profile for FF3.

Existing entries in PWM (from FF 2.x) work in the FF nightlies, so that when I go to a site that has a password setup in PWM, PWM properly enters the relevant information and I can log on.

However, if I look at PWM itself, all (yes, all) of the boxes for entering information are empty. So, if I want to see that the password, URL, etc., are for sites where PWM is working with FF3 nightly releases, I see nothing at all.

Thanks, John. It's really not necessary to do this. It's unlikely to help me. Many of the problems probably stem from stricter compliance to the w3c DOM. Specifically, a DOM node created in document A cannot be inserted into document B. Example:
Code: [Select]
var john = document.createElement("john");
document2.appendElement(john); // illegal in FF 3.x because john was not created on document2
IIRC, there's code like that all over PasswordMaker that needs to be changed.

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #8 on: December 13, 2007, 04:51:21 PM »
Ouch... so does this mean that a FF3 version will be a major undertaking?

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #9 on: December 13, 2007, 05:13:01 PM »
Ouch... so does this mean that a FF3 version will be a major undertaking?

yes

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #10 on: December 30, 2007, 04:49:24 AM »
I should have a PasswordMaker beta that works with Firefox 3 shortly.

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #11 on: December 30, 2007, 02:10:51 PM »
I should have a PasswordMaker beta that works with Firefox 3 shortly.
Eric is 'da man'! :)

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #12 on: December 30, 2007, 08:01:25 PM »
Beta released. See here.

Offline TheBashar

  • Normal Members
  • *
  • Posts: 3
Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #13 on: January 02, 2008, 09:49:14 PM »
Thank you, Eric!  Works great in my simple tests!

PasswordMaker Forums

Re: PWMaker 1.7 + Firefox 3 B1 + Vista = Broken
« Reply #13 on: January 02, 2008, 09:49:14 PM »