Author Topic: Firefox on Vista problems  (Read 7235 times)

Offline rgerrans

  • Normal Members
  • *
  • Posts: 4
Firefox on Vista problems
« on: September 11, 2007, 05:09:12 PM »
I've been having problems for a while on Firefox running on Vista and think I have narrowed it down to PasswordMaker.  Firefox frequently stops connecting to websites (it just sits in loading mode) and I have to shutdown and restart.  Shutdowns are also leaving the program running at a very reduced level in memory and require a process kill to get rid of them.  I finally started turning on and off add-ins to see if any of them were causing the problem and it turned out that it looks like PasswordMaker is the culprit.  I just tried installing the latest beta to see if that made any differences but it has the same issues.

Anyone else seen this problem / have a work around, or any additional logs or information I can provide to help with troubleshooting / recreating the problem.

TIA,

-Ron

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: Firefox on Vista problems
« Reply #1 on: September 11, 2007, 05:15:10 PM »
Sorry, can't help with Vista problems - that is one piece of crapware that my computer will never see...

You have my sympathies...

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: Firefox on Vista problems
« Reply #2 on: September 11, 2007, 05:28:46 PM »
I've been having problems for a while on Firefox running on Vista and think I have narrowed it down to PasswordMaker.  Firefox frequently stops connecting to websites (it just sits in loading mode) and I have to shutdown and restart.  Shutdowns are also leaving the program running at a very reduced level in memory and require a process kill to get rid of them.  I finally started turning on and off add-ins to see if any of them were causing the problem and it turned out that it looks like PasswordMaker is the culprit.  I just tried installing the latest beta to see if that made any differences but it has the same issues.

Anyone else seen this problem / have a work around, or any additional logs or information I can provide to help with troubleshooting / recreating the problem.

TIA,

-Ron

Which version of Firefox?
Which websites, and are they consistent?
Are you using auto-populate?

Offline rgerrans

  • Normal Members
  • *
  • Posts: 4
Re: Firefox on Vista problems
« Reply #3 on: September 11, 2007, 05:55:57 PM »
Firefox v2.0.0.6

The problem is with all websites independent of if I'm using PasswordMaker to authenticate at the time of "disconnect".  The only reason I think it is PasswordMaker is that when I disable the add on the problem seems to go away (at least for the periods of time I can run without needing to turn it back on to get into a website).

Thanks,

-Ron

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: Firefox on Vista problems
« Reply #4 on: September 11, 2007, 06:08:28 PM »
Firefox v2.0.0.6

The problem is with all websites independent of if I'm using PasswordMaker to authenticate at the time of "disconnect".  The only reason I think it is PasswordMaker is that when I disable the add on the problem seems to go away (at least for the periods of time I can run without needing to turn it back on to get into a website).

Thanks,

-Ron

Would you be able to try PasswordMaker in a new Firefox profile to absolutely rule out any other addon and Firefox configuration setting? If you can reproduce this problem in a new Firefox profile with nothing else but PasswordMaker installed, it is indeed a PasswordMaker bug. Please let me know.

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: Firefox on Vista problems
« Reply #5 on: September 11, 2007, 06:56:21 PM »
Sorry for my previous message - it sounded much harsher than intended (I always forget to use the little smileys)...

One thing I thought of - did you make any changes to the global settings? Some of those may behave differently in Vista...

Offline rgerrans

  • Normal Members
  • *
  • Posts: 4
Re: Firefox on Vista problems
« Reply #6 on: September 11, 2007, 07:16:58 PM »
tanstaafl,

No worries.  My home religion is Ubuntu, so I understand.

It looks like I didn't test enough before posting here...*blush*  I did finally get it to repeat the problem while PasswordMaker was disabled so it looks like it is something else causing the issue.

Oh well, back to the drawing board.......

Sorry for wasting everyone's time, and I appreciate the quick responses.

-Ron

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Re: Firefox on Vista problems
« Reply #7 on: September 11, 2007, 07:33:45 PM »
tanstaafl,

No worries.  My home religion is Ubuntu, so I understand.

It looks like I didn't test enough before posting here...*blush*  I did finally get it to repeat the problem while PasswordMaker was disabled so it looks like it is something else causing the issue.

Oh well, back to the drawing board.......

Sorry for wasting everyone's time, and I appreciate the quick responses.

-Ron

No problem. Good luck figuring it out. For what it's worth, creating a new Firefox profile always solves whatever weirdness I encounter with Firefox. The downside is you have to reinstall your extensions one-by-one. With PasswordMaker, you just need to copy passwordmaker.rdf from the old profile directory to the new one.

Offline tanstaafl

  • God Member
  • ******
  • Posts: 1363
Re: Firefox on Vista problems
« Reply #8 on: September 11, 2007, 07:36:42 PM »
Yeah, good luck! I've been forced into supporting Vista for some of our users at the office, and really grown to hate it - as you can see... ;)

Offline rgerrans

  • Normal Members
  • *
  • Posts: 4
Re: Firefox on Vista problems
« Reply #9 on: September 11, 2007, 07:37:06 PM »
Good suggestion, thanks.

PasswordMaker Forums

Re: Firefox on Vista problems
« Reply #9 on: September 11, 2007, 07:37:06 PM »