Author Topic: PWM 1.6.1 does not populate correct passwords  (Read 4966 times)

Offline cscj01

  • Normal Members
  • *
  • Posts: 5
PWM 1.6.1 does not populate correct passwords
« on: November 25, 2006, 12:00:01 AM »
After upgrading to Firefox 2.0 and PWM 1.6.1, my passwords are not correctly populated.  In fact, every time I use the "Populate This Field" option after right-clicking in the password field, PWD supplies a default 8 character password even though the correct password may be longer.  I must open PWD, click on the Account that I am attempting to Log On to, copy the displayed password in the left panel, then paste it into the web field.  Then the Log On process is completed successfully.  This happens at most of my Accounts.  Does anyone have any idea what is happening?  I used PWM successfully for a good while on Firefox 1.5.x with no problems.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
PWM 1.6.1 does not populate correct passwords
« Reply #1 on: November 30, 2006, 12:07:59 AM »
Hi,

Since you're using auto-populate/cool-key to populate the fields, it sounds like your URL matching patterns (previously called "When URL contains") didn't migrate properly. Check the URL matching patterns and change appropriately. Sorry for the inconvenience.

Offline cscj01

  • Normal Members
  • *
  • Posts: 5
PWM 1.6.1 does not populate correct passwords
« Reply #2 on: December 01, 2006, 06:05:04 PM »
Eric,

After reading your response, I noticed that many patterns did migrate.  I am now wondering if I perhaps am using PWM incorrectly.  Would you answer just a few questions to clarify my thoughts?

(1) Does the "Use the following URL to calculate the generated password" field (hereinafter referred to simply as URL field) just provide a factor in the password generator routine?;

(2) If the URL field is blank, does PWD use the default to populate a password field?;

(3)  Do patterns need to be in the Patterns List for the Auto-populate/Coolkey to work correctly?  More to the point, if I have a pattern in the URL field, do I also need to have a pattern in the list?;

(4)  Should I always have my patterns in the list rather than in the URL field?

Thanks for the assistance.

Cecil Carpenter

Offline Miquel 'Fire' Burns

  • Administrator
  • *****
  • Posts: 1157
  • Programmer
PWM 1.6.1 does not populate correct passwords
« Reply #3 on: December 01, 2006, 07:23:55 PM »
1) Yes.
2) No, there's no url used to calculate the password. As other things may be blank, that basically just leaves the master password.
3) Yes. The URL field is not a pattern BTW.
4) Yes.
"I'm not drunk, just sleep deprived."

PasswordMaker Forums

PWM 1.6.1 does not populate correct passwords
« Reply #3 on: December 01, 2006, 07:23:55 PM »