Author Topic: Linux problem with 0.7  (Read 8410 times)

Offline Brathna

  • Normal Members
  • *
  • Posts: 8
Linux problem with 0.7
« on: July 15, 2005, 05:26:23 PM »
I've used PasswordMaker 0.6 under linux and everything works fine, but there's a little problem with 0.7.  Every time I load up the PasswordMaker window, I get an error:

Quote
Unable to copy [xpconnect wrapped nslFile] to [xpconnect wrapped nslFile]

Do you have sufficient read/write privileges?

After I click OK on the message box, PasswordMaker shows up and works like normal.

What is 0.7 doing differently from 0.6 that might be causing this error?

Thanks for any help.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Linux problem with 0.7
« Reply #1 on: July 15, 2005, 05:51:34 PM »
Hi,
There's an icon file missing in passwdmaker-0.7.xpi for Linux. It should be in

%Profile%/extensions/{5872365E-67D1-4AFD-9480-FD293BEBD20D}/defaults/passwordmakerdlg.xpm
and gets copied to (if it's not already there)
%MozDir%/chrome/icons/default/passwordmakerdlg.xpm

where %MozDir% is your Mozilla/Firefox installation directory, and %Profile% is your profile directory.

This file is the icon the passwordmaker dialog (a ring). On windows, it's a .ico file -- which is in the passwdmaker-0.7.xpi. I forgot to put an xpm version there. You can safely ignore the warning, or give me a day or so to make the .XPM. I'll post it here and you can manually copy it to %Profile%/extensions/{5872365E-67D1-4AFD-9480-FD293BEBD20D}/defaults/passwordmakerdlg.xpm. That will fix the problem.

Sorry for the inconvenience,
Eric

Offline Brathna

  • Normal Members
  • *
  • Posts: 8
Linux problem with 0.7
« Reply #2 on: July 15, 2005, 06:23:01 PM »
I just created an empty .xpm in:

%MozDir%/chrome/icons/default/passwordmakerdlg.xpm

And I don't get that error message anymore.

Thanks for the quick help, and awesome extension; I've been using it since 0.1.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Linux problem with 0.7
« Reply #3 on: July 15, 2005, 07:02:07 PM »
You're welcome... glad to hear you like it!

-eric

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Linux problem with 0.7
« Reply #4 on: July 16, 2005, 05:48:24 PM »
Attached is passwordmakerdlg.xpm for anyone who'd like it before the next release.

-Eric

Offline Brathna

  • Normal Members
  • *
  • Posts: 8
Linux problem with 0.7
« Reply #5 on: July 23, 2005, 05:08:12 AM »
I deleted the .xpm I created before and installed 0.7.1. There's a passwordmakerdlg.xpm in my profile directory now, but not in the %MozDir%, and I still get that error.

I don't think it will copy over, unless the browser is running as root or firefox is installed in the user's personal directory.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3353
Linux problem with 0.7
« Reply #6 on: July 23, 2005, 03:32:38 PM »
Thanks, Brathna. The error message has been removed from the forthcoming PasswordMaker release. Now it simply fails silently.

-Eric

PasswordMaker Forums

Linux problem with 0.7
« Reply #6 on: July 23, 2005, 03:32:38 PM »