anything

Author Topic: Stop multiple account pop-up after login  (Read 17104 times)

Offline ignatius.reilly

  • Jr. Member
  • **
  • Posts: 28
Stop multiple account pop-up after login
« on: November 19, 2010, 07:39:20 AM »
I have several accounts defined on a URL.
I would expect that the PWM pop-up window show up only once, in the login screen, and that it does not show any more once logged.

Of course this problem can be avoided when there is a specific login URL, such as mydomain.com/login, which can be used as pattern match, but this is not always the case.

I would suggest that the pop-up show up only when either:
- there is a password text box on the page
- there is an auto-populate field match on the page

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1362
Re: Stop multiple account pop-up after login
« Reply #1 on: November 19, 2010, 11:50:45 AM »
The auto-pop-up works as designed - by matching (one of) the defined URL(s). What you need to do is make the URL match more precisely - e.g., if you're using:

https://www.google.com/*

as the pattern to match on for gmail, change it to:

https://www.google.com/accounts/ServiceLogin?*

(although not the best example, because www.google.com changes to mail.google.com after logging in)

Personally I don't like the auto-popup feature and just use the coolkey when I want to log in, so never have an opportunity to experience this problem...

Offline ignatius.reilly

  • Jr. Member
  • **
  • Posts: 28
Re: Stop multiple account pop-up after login
« Reply #2 on: November 19, 2010, 12:10:48 PM »
Yes, indeed
(as suggested in http://forums.passwordmaker.org/index.php/topic,501.msg809510.html#msg809510)

But is is not always possible to isolate a login URL pattern

Quote
Personally I don't like the auto-popup feature and just use the coolkey when I want to log in, so never have an opportunity to experience this problem...
Can the pop-up feature be disabled?

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1362
Re: Stop multiple account pop-up after login
« Reply #3 on: November 19, 2010, 12:31:59 PM »
Quote
Personally I don't like the auto-popup feature and just use the coolkey when I want to log in, so never have an opportunity to experience this problem...

Can the pop-up feature be disabled?

Sure - uncheck the 'Automatically populate username and password fields...' option on the URLs tab (in advanced settings) for the account in question...

Do the same for the 'Defaults' account to prevent new accounts from having this enabled by default.

Then just use ALT-` when on the login page... if nothing happens, there's a problem with the URL matching...

Offline ignatius.reilly

  • Jr. Member
  • **
  • Posts: 28
Re: Stop multiple account pop-up after login
« Reply #4 on: November 20, 2010, 08:45:58 AM »
Thanks for the tip, Tanstaafl

Hmmm... I did as suggested, and I still get the pop-up. Strange...

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1362
Re: Stop multiple account pop-up after login
« Reply #5 on: November 21, 2010, 07:43:32 PM »
Thanks for the tip, Tanstaafl

Hmmm... I did as suggested, and I still get the pop-up. Strange...

Did you disable the auto-populate for just the Defaults? Or for the specific account being triggered? Or both?

If you really did disable it for the account in question and are certain that it is that account being triggered, then I have personally seen having a field added on the 'Advanced Auto-Populate' tab cause this...

Offline ignatius.reilly

  • Jr. Member
  • **
  • Posts: 28
Re: Stop multiple account pop-up after login
« Reply #6 on: November 22, 2010, 03:49:35 PM »
Yes I disabled for both
And indeed I have a 'Advanced Auto-Populate' field, so this would be the reason.

This would be a bug, wouldn't it?

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1362
Re: Stop multiple account pop-up after login
« Reply #7 on: November 22, 2010, 05:15:19 PM »
I don't think so... the problem happens when, when you add the field, you leave the 'Notify when field doesn't exist' option enabled...

I had this problem once with multiple accounts, because I had copied one that had that field already added, and since the field that did exist on  the original I copied from, but didn't exist on the new account, it caused the pop-up...

So just remove that field from the problem account and you should be good to go...

Offline ignatius.reilly

  • Jr. Member
  • **
  • Posts: 28
Re: Stop multiple account pop-up after login
« Reply #8 on: November 28, 2010, 12:32:00 PM »
Well, no, it doesn't seem to work as advertised. I still get the pop-op.

No big deal, though.

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1362
Re: Stop multiple account pop-up after login
« Reply #9 on: November 29, 2010, 12:22:51 PM »
Well, no, it doesn't seem to work as advertised. I still get the pop-op.

Only other thing I can think of is you have another account with that URL in the URL list... I have hundreds of accounts, and copy/dupe them all the time, and it has happened to me more than once...

Oh well, sorry I couldn't help...
« Last Edit: November 30, 2010, 11:21:41 AM by tanstaafl »

Offline ignatius.reilly

  • Jr. Member
  • **
  • Posts: 28
Re: Stop multiple account pop-up after login
« Reply #10 on: November 30, 2010, 11:07:08 AM »
I checked that as well, not so :-)

No big deal, though.

Still, this thread started as a FR, that I still believe makes sense... Definitely not a high priority one, though.

Offline ignatius.reilly

  • Jr. Member
  • **
  • Posts: 28
Re: Stop multiple account pop-up after login
« Reply #11 on: April 01, 2011, 11:38:56 AM »
Still not considered as a valid feature request?  ;)

PasswordMaker Forums

Re: Stop multiple account pop-up after login
« Reply #11 on: April 01, 2011, 11:38:56 AM »