Author Topic: Update or not  (Read 3550 times)

Offline r.dirksen

  • Newbie
  • *
  • Posts: 4
Update or not
« on: July 23, 2009, 08:00:02 AM »
I use PWM already for years on various XP machines and FireFox versions and since a few months I encounter a problem.

Whenever I start Firefox (currentely 3.5.1 but also in the version before that) PWM is not working: I can't start it. Looking in Extra > Add-ons I see that PWM is greyed-out with an exclamation mark.
I search for Updates and it says a security update is installed and I have to restart FF.
then everything just works fine.

Next Time same story.

I uninstalled PWM and reinstalled it. No success.

Anybody an idea?
Plans without action are daydreams,
Actions without a plan are a nightmare.

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1362
Re: Update or not
« Reply #1 on: July 23, 2009, 11:42:08 AM »
Works fine for me, I'm also on 3.5.1...

When you say '... Extra > Add-ons ...', I'm assuming you mean '... Tools > Add-ons ...'?

The version that you download from the Addons site isn't explicitly updated to work out of the box with Firefox 3.5.*, but you can easily fix yours...

Download it to your desktop then open it (I use 7zip, which treats .xpi files like zip files, so it opens like a folder), then Edit the install.rdf file, and in  the Firefox section, change the '3.0b3pre' to '3.5.*', then save the file back into the .xpi file, and close it.

Now, install this updated extension, and it will work out of the box on 3.5.* versions of FFox...

If you have trouble doing the above, I can email you my copy of the extension if you like...

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3348
    • http://passwordmaker.org/
Re: Update or not
« Reply #2 on: July 23, 2009, 12:03:17 PM »
The version that you download from the Addons site isn't explicitly updated to work out of the box with Firefox 3.5.*, but you can easily fix yours...

Download it to your desktop then open it (I use 7zip, which treats .xpi files like zip files, so it opens like a folder), then Edit the install.rdf file, and in  the Firefox section, change the '3.0b3pre' to '3.5.*', then save the file back into the .xpi file, and close it.

Now, install this updated extension, and it will work out of the box on 3.5.* versions of FFox...

If you have trouble doing the above, I can email you my copy of the extension if you like...

Ah, I forgot about that. I will update the version on Mozilla Addons. Yes, that means a new version ! Do you think this is original poster's problem?

Eric

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1362
Re: Update or not
« Reply #3 on: July 23, 2009, 12:37:48 PM »
I think so... I seem to recall a similar problem after 3.0 final was released... but I keep a local repository for all my installers (including extensions), and fixed mine a long time ago...

Offline tanstaafl

  • Administrator
  • *****
  • Posts: 1362
Re: Update or not
« Reply #4 on: July 23, 2009, 12:40:29 PM »
I will update the version on Mozilla Addons. Yes, that means a new version !

Does that mean there are some other changes you have made that will now be available to us?

:)

Offline r.dirksen

  • Newbie
  • *
  • Posts: 4
Re: Update or not
« Reply #5 on: July 23, 2009, 09:55:43 PM »

Quote
When you say '... Extra > Add-ons ...', I'm assuming you mean '... Tools > Add-ons ...'?

Sure, Dutch version Tools is translated to Extra.

and when I search for updates it says that a "compatibility update" has been installed.

have to install 7-zip do do the trick.

I'll keep you  posted on the results

Rob
Plans without action are daydreams,
Actions without a plan are a nightmare.

Offline Eric H. Jung

  • grimholtz
  • Administrator
  • *****
  • Posts: 3348
    • http://passwordmaker.org/
Re: Update or not
« Reply #6 on: August 06, 2009, 12:35:02 AM »
you can upgrade to 1.7.3 now to get this automatically.

PasswordMaker Forums

Re: Update or not
« Reply #6 on: August 06, 2009, 12:35:02 AM »

 

anything